Software Documentation

Inventory management and importing effectsDocumentation

Intermediate Last updated: November 9, 2019

3 Importing effects from Finale Business

Converting effect inventories from Finale Business to Finale 3D is a two step process.  The first step you can do in one sitting.  The second step is usually something you do incrementally.

  1. Get the effects to show up in 3D.  Instructions for this step depend on whether your effects are in “My Fireworks” or in a Master Inventory / Finale Inventory. Finale Business doesn’t have an export function for “My Fireworks”, so some manual work is required to transfer them to Finale 3D.  The Master Inventory / Finale Inventory effects are easier, because you can link Finale 3D to your Master Inventory / Finale Inventory directly.  In both cases, after getting the effects to show up in Finale 3D, you’ll need to do some editing to handle differences in the way Finale Business and Finale 3D represent effects.
  2. Improve the quality of the simulations.  Having imported or connected your inventory file to Finale 3D, the next step is to improve the simulations.  Custom simulations made using the colorful graphics editing panels at the top of the Finale Business screen do not carry over to Finale 3D, but the VDL descriptions do carry over, so simulations based on VDL descriptions will generally look reasonable with minor editing of the VDL or other specifications like prefire and duration.  To fine tune the graphics in Finale 3D you use the Finale 3D effect editor (not yet available, as of November 2019), and you create cake simulations from individual effects using the “Effects > Create cake from selected items…” function.

 

Get the effects to show up in 3D

If your effects are in a Master Inventory / Finale Inventory, then please connect them to Finale 3D from the “finale3d.com > My Account > Connect To Finale Inventory” page, as described in Account setup. The inventory will then appear in your effects window in Finale 3D, and also in your Finale Business inventory view. Please note that there are some tricky compatibility issues for making effect simulations look good in both Finale Business and Finale 3D concurrently, so if you are planning on using both software programs then you need to be delicate as described in Inventory compatibility with Finale Business (and how to fix cakes).

If your effects are in “My Fireworks” in Finale Business, then you’ll need to copy them out of Finale Business in an HBS file and import them into Finale 3D. Once imported into Finale 3D, these effects will no longer have any connection to the “My Fireworks” of Finale Business, so you can improve the simulations in Finale 3D without worrying about backward compatibility. To copy the effects out of “My Fireworks”, you need to create a show in Finale Business with one each of each of your effects, one after another. Then save the show as an HBS file and import it into Finale 3D with “File > Import > Import Effects from HBS file…”.

Once your effects show up in Finale 3D as rows in the effects window, you will probably need to edit some of the simulations or the effect parameters to make them look good. The editing process depends on how the simulations were created in Finale Business originally, as described in Table 1. For most effects, the process begins with right-clicking on the effect row in the effects window in Finale 3D, and selecting “Edit this effect simulation or rack…” from the context menu. That command brings up a dialog that incorporates the original VDL description and any other parameters that affect the simulation, such as the prefire, duration, height, and number of shells if it is chain. The dialog displays the combined information in the “Input description” field, which you can edit. As you edit the description, you can see the interpretation of what you are typing, and resulting specifications of the simulation below, in the green read-only boxes.

Table 1 – Editing process to adapt Finale Business effect simulations to Finale 3D

Simulation in Finale Business What to expect in Finale 3D How to fix it in Finale 3D
Imported or created with the control-G “Create simulation” dialog. Simulation should look pretty good. No editing required. Optionally you can add adjectives like “Big” or “Dense” to the VDL as described in VDL effect adjustment terms.
Created on the timeline using “Combine into cake…” (cakes only) . Simulation may be missing or bad but it probably will contain the correct number of effects and correct timing. If the cake simulation has the correct number of effects and timing but the effects themselves look bad, insert the cake into a test show in Finale 3D and do “Effects > Break apart cake” to break it apart into its constituents arranged on the timeline.  Then right click on the constituents to edit them, and/or change the timing by rearranging them on the timeline.  When they look right do “Effects > Create cake from selected items…” to re-create the cake.   Alternatively, if you just want to create a quick placeholder simulations, follow the instructions in Creating or importing a simple “placeholder” cake simulation.
Customized using the colorful graphics editing panels. Finale 3D doesn’t use the customizations, but the simulation may look okay if it was originally created with the “Create simulation” dialog in Finale Business. Fine tune the effect simulation with the Finale 3D effect editor (right-click on the row in the effect window to customize using the effect editor).

 

Improve the quality of the simulations

To fine tune the graphics in Finale 3D you can use the Finale 3D effect editor (currently in beta test, as of May 2019), and you can create cake simulations from individual effects using the Effects > Create cake from selected items…” function. You can also create complex effects including multi-effect cakes by typing in the VDL directly, but the syntax of VDL for cakes is a little complicated.

You can do some degree of customization by adding adjectives like “Big” and “Dense” to the VDL, as described in VDL effect adjustment terms. You can also edit the prefire, duration, height, and chain number of shells (devices) directly in the columns of the effect table. These parameters will apply to the simulation directly. For example, if you change the duration of a comet from 1 second to 10 seconds without changing its height, the comet will shoot up into the air to an apex at its original height but then it will come crashing back down to the ground. Changing the prefire of a shell affects the time before the shell breaks without affecting the height of the apex of the full trajectory, so a prefire of 0.1 seconds would cause a shell to break on the way up, looking like a flower pot. Changing the duration of a shell affects the lifetime of the stars; whereas changing the duration of a cake affects the timing of the shots within the cake. The full explanations are shown in Table 2.

Table 2 – Editing specifications fields directly in the effect table

Field (column) For shells For comets and mines For cakes and candles
Prefire Time to break, adjusts whether the break is before or after the apex. Does not affect exit velocity and thus does not affect the apex of the trajectory. Does not affect simulation but does affect the scripting delay between ignition and effect time on the timeline Affects the lift time of shells in the cake as described in detail in Cake and candle duration (and prefire)
Duration Lifetime of stars, adjusts whether stars expire quickly or linger all the way to the ground. Lifetime of stars, adjusts whether stars expire quickly or linger all the way to the ground. Affects the timing of the cake shots (first launch to last break) as described in detail in Cake and candle duration (and prefire)
Height Height of the apex of the trajectory in meters. Height of the apex of the trajectory in meters. To make “Ultra-fast” or “Laser” comets, set the height high and the duration small. Affects the height of all effects in the cake.
Devices Affects number of shells in the chain, if the item is a chain. No effect. No effect.